Skip to main content

Observable Discrepancy

CVE-2024-21484

Severity Medium
Score 5.9/10

Summary

The package jsrsasign versions prior to 11.0.0 are vulnerable to Observable Discrepancy via the "RSA PKCS1.5" or "RSAOAEP" decryption process. An attacker can decrypt ciphertexts by exploiting this vulnerability. Exploiting this vulnerability requires the attacker to have access to a large number of ciphertexts encrypted with the same key. Workaround This vulnerability can be mitigated by finding and replacing "RSA" and "RSAOAEP" decryption with another crypto library.

  • HIGH
  • NETWORK
  • NONE
  • UNCHANGED
  • NONE
  • NONE
  • HIGH
  • NONE

CWE-203 - Observable Discrepancy

The product behaves differently or sends different responses under different circumstances in a way that is observable to an unauthorized actor, which exposes security-relevant information about the state of the product, such as whether a particular operation was successful or not.

Advisory Timeline

  • Published