Skip to main content

Uncontrolled Resource Consumption

CVE-2024-20965

Severity Medium
Score 4.9/10

Summary

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Optimizer). This issue affects versions through 8.0.35, and 8.1.0 through 8.2.0. Easily exploitable vulnerability allows high privileged attackers with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. This issue also affects mysql-cluster versions through 7.5.32, 7.6.2 through 7.6.28, 8.0.16 through 8.0.35, and 8.1.0 through 8.2.0.

  • LOW
  • NETWORK
  • NONE
  • UNCHANGED
  • NONE
  • HIGH
  • NONE
  • HIGH

CWE-400 - Uncontrolled resource consumption

An uncontrolled resource allocation attack (also known as resource exhaustion attack) triggers unauthorized overconsumption of the limited resources in an application, such as memory, file system storage, database connection pool entries, and CPU. This may lead to denial of service for valid users and degradation of the application's functionality as well as that of the host operating system.

Advisory Timeline

  • Published