Skip to main content

Improper Input Validation


Severity High
Score 8.8/10


Adobe Commerce and Magento Open Source versions through 2.3.7-p3, 2.4.0 through 2.4.3-p2, and 2.4.4 are affected by an improper input validation vulnerability. An authenticated attacker can trigger an insecure direct object reference in the `V1/customers/me` endpoint to achieve information exposure and privilege escalation.

  • LOW
  • HIGH
  • NONE
  • LOW
  • HIGH
  • HIGH

CWE-20 - Improper Input Validation

The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

Advisory Timeline

  • Published