Skip to main content

Improper Input Validation

CVE-2022-39272

Severity Medium
Score 4.3/10

Summary

Flux is an open and extensible continuous delivery solution for Kubernetes. In github.com/fluxcd/flux2 Versions 0.1.0 prior to 0.35.0, github.com/fluxcd/helm-controller 0.0.1-alpha-1 prior to 0.24.0, github.com/fluxcd/image-automation-controller 0.1.0 prior to 0.26.0, github.com/fluxcd/image-reflector-controller 0.1.0 prior to 0.22.0, github.com/fluxcd/kustomize-controller 0.0.1-alpha-1 prior to 0.29.0, github.com/fluxcd/notification-controller 0.0.1-alpha-1 prior to 0.27.0 and github.com/fluxcd/source-controller 0.0.1-alpha-1 prior to 0.30.0 are subject to a Denial of Service. Users that have permissions to change Fluxs objects, either through a Flux source or directly within a cluster, can provide invalid data to fields ".spec.interval" or ".spec.timeout" (and structured variations of these fields), causing the entire object type to stop being processed. As a workaround, Admission controllers can be employed to restrict the values that can be used for fields ".spec.interval" and ".spec.timeout", however upgrading to the latest versions is still the recommended mitigation.

  • LOW
  • NETWORK
  • NONE
  • UNCHANGED
  • NONE
  • LOW
  • NONE
  • LOW

CWE-20 - Improper Input Validation

The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

Advisory Timeline

  • Published