Skip to main content

Improper Input Validation

CVE-2022-35966

Severity High
Score 7.5/10

Summary

TensorFlow is an open source platform for machine learning. If `QuantizedAvgPool` is given `min_input` or `max_input` tensors of a nonzero rank, it results in a segfault that can be used to trigger a denial of service attack. The fix will be included in TensorFlow 2.10.0. This vulnerability was also fixed in TensorFlow 2.9.2, TensorFlow 2.8.3, and TensorFlow 2.7.4 as these are also affected and still in supported range. There are no known workarounds for this issue. This issue affects versions prior to 2.7.4, 2.8.x prior to 2.8.3, and 2.9.x prior to 2.9.2.

  • LOW
  • NETWORK
  • NONE
  • UNCHANGED
  • NONE
  • NONE
  • NONE
  • HIGH

CWE-20 - Improper Input Validation

The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

Advisory Timeline

  • Published