Skip to main content

Reachable Assertion

CVE-2022-35963

Severity High
Score 7.5/10

Summary

TensorFlow is an open source platform for machine learning. The implementation of `FractionalAvgPoolGrad` does not fully validate the input `orig_input_tensor_shape`. This results in an overflow that results in a `CHECK` failure which can be used to trigger a denial of service attack. This issue affects TensorFlow versions prior to 2.7.4, 2.8.x prior to 2.8.3, and 2.9.x prior to 2.9.2. There are no known workarounds for this issue.

  • LOW
  • NETWORK
  • NONE
  • UNCHANGED
  • NONE
  • NONE
  • NONE
  • HIGH

CWE-617 - Reachable Assertion

The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.

Advisory Timeline

  • Published