Improper Input Validation
The vulnerability was found in Moodle prior to 3.9.15, 3.10,x, 3.11.x prior to 3.11.8, 4.0.x prior to 4.0.2, occur due to improper input validation when parsing "PostScript" code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.
CWE-20 - Improper Input Validation
The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.