Skip to main content

Product UI does not Warn User of Unsafe Actions

CVE-2022-34478

Severity Medium
Score 6.5/10

Summary

The '<code>ms-msdt</code>', '<code>search</code>', and '<code>search-ms</code>' protocols deliver content to Microsoft applications, bypassing the browser, when a user accepts a prompt. These applications have had known vulnerabilities, exploited in the wild (although we know of none exploited through Thunderbird), so in this release Thunderbird has blocked these protocols from prompting the user to open them. This bug only affects Thunderbird on Windows. Other operating systems are unaffected. This vulnerability affects Firefox versions prior to 102, Firefox ESR versions prior to 91.11, and Thunderbird versions prior to 91.11.

  • LOW
  • NETWORK
  • HIGH
  • UNCHANGED
  • REQUIRED
  • NONE
  • NONE
  • NONE

CWE-356 - Product UI does not Warn User of Unsafe Actions

The software's user interface does not warn the user before undertaking an unsafe action on behalf of that user. This makes it easier for attackers to trick users into inflicting damage to their system.

Advisory Timeline

  • Published