Skip to main content

Out-of-bounds Write

CVE-2022-33099

Severity High
Score 7.5/10

Summary

An issue in the component "luaG_runerror" of Lua leads to a heap-buffer overflow when a recursive error occurs in versions prior to 5.4.5.

  • LOW
  • NETWORK
  • NONE
  • UNCHANGED
  • NONE
  • NONE
  • NONE
  • HIGH

CWE-787 - Out-of-Bounds Write

Out-of-bounds write vulnerability is a memory access bug that allows software to write data past the end or before the beginning of the intended buffer. This may result in the corruption of data, a crash, or arbitrary code execution.

References

Advisory Timeline

  • Published