Skip to main content

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')

CVE-2022-30033

Severity High
Score 7.8/10

Summary

Tenda TX9 Pro V22.03.02.10 is vulnerable to Buffer Overflow via the functtion setIPv6Status() in httpd module.

  • LOW
  • NETWORK
  • NONE
  • NONE
  • NONE
  • COMPLETE

CWE-120 - Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')

The program copies an input buffer to an output buffer without verifying that the size of the input buffer is less than the size of the output buffer, leading to a buffer overflow.

References

Advisory Timeline

  • Published