Skip to main content

Exposure of Resource to Wrong Sphere

CVE-2022-21126

Severity High
Score 7.8/10

Summary

The package com.github.samtools:htsjdk before 3.0.1 are vulnerable to Creation of Temporary File in Directory with Insecure Permissions due to the "createTempDir()" function in "util/IOUtil.java" not checking for the existence of the temporary directory before attempting to create it.

  • LOW
  • LOCAL
  • HIGH
  • UNCHANGED
  • NONE
  • LOW
  • HIGH
  • HIGH

CWE-668 - Exposure of Resource to Wrong Sphere

The product exposes a resource to the wrong control sphere, providing unintended actors with inappropriate access to the resource.

Advisory Timeline

  • Published