Skip to main content

Improper Encoding or Escaping of Output

CVE-2020-36599

Severity High
Score 9.8/10

Summary

The package OmniAuth before 1.9.2 and 2.0.0.pre.rc1 does not escape the message_key value at "lib/omniauth/failure_endpoint.rb"

  • LOW
  • NETWORK
  • HIGH
  • UNCHANGED
  • NONE
  • NONE
  • HIGH
  • HIGH

CWE-116 - Improper Encoding or Escaping of Output

The software prepares a structured message for communication with another component, but encoding or escaping of the data is either missing or done incorrectly. As a result, the intended structure of the message is not preserved.

Advisory Timeline

  • Published