Skip to main content

Improper Privilege Management

CVE-2019-20886

Severity High
Score 7.5/10

Summary

An issue was discovered in Mattermost Server before 5.8.0. The first user is sometimes inadvertently a system admin.

  • LOW
  • NETWORK
  • HIGH
  • UNCHANGED
  • NONE
  • NONE
  • NONE
  • NONE

CWE-269 - Improper Privilege Management

An effective privilege management infrastructure provides valid users with required access and privileges across heterogeneous technology environments. An application with a faulty privilege management infrastructure allows higher than authorized privileges or enables privilege escalation. This can lead to security incidents such as system infiltration, data breach, and complete system takeover.

References

Advisory Timeline

  • Published