Skip to main content

Improper Authentication


Severity High
Score 7.5/10


The FCGI (aka Fast CGI) module is vulnerable through version 0.73. Versions 0.70 through 0.73 as used by CGI::Fast, use environment variable values from one request during the processing of a later request, which allows remote attackers to bypass authentication via crafted HTTP headers. This issue also affects CGI in versions prior to 3.56.

  • LOW
  • NONE

CWE-287 - Improper Authentication

Improper (or broken) authentication attacks are widespread, and have accounted for many of the worst data breaches in recent years. Improper authentication attacks are a class of vulnerabilities where an attacker impersonates a legitimate user by exploiting weaknesses in either session management or credential management to gain access to the user’s account. This can result in disclosure of sensitive information, and can lead to system compromise, theft, identity theft, and fraud.

Advisory Timeline

  • Published